Start a new topic

My camera keeps freezing on me

I have a simple set up with our PTZ cam for our church. USB from iMac to camera. I have checked all the settings. internet runs great. The problem is the video freezes in the middle of the service and it only freezes on me when I use the software call (Ecamm)to livestream our services. However when I use (OBS software) it doesn’t freeze and I don’t like OBS I want to use Ecamm. Anyhow, I have our guy ready to deactivate then activate so it can function again when it freezes or glitch. I also was looking to purchase a second camera but I wont until I figure out this problem. Thank you. Is it Software or Hardware? I have a PTZ Optics 20x USB (GEN-2) I wish I had pictures of it when it does it. I’ll definitely try to get one if it happens again which I’m sure it will. Is it hardware or software?

1 person has this question

Hi King,


I would first recommend updating the firmware of your PT20X-USB to ensure that you are using the latest and greatest updates for the camera.


Firmware updates can be acquired using the PTZOptics Firmware Finder and your cameras serial number.


If the issue still occurs after the firmware update and only occurs in ECamm, but not OBS, this would suggest a software issue as your problem.


We are happy to work with you and ECamm to solve this issue in the event there is an issue between the products if needed.


I hope the suggestions above are able to rectify your issue but if not please do not hesitate to return to the forums or reach out to our amazing support team


PTZOptics Support Information

Phone: 1-800-486-5276 x.1004

e-Mail: support@ptzoptics.com

Ticket: https://help.ptzoptics.com/support/home

(must be signed in / logged in to submit ticket)



Hello all


I am having the exact problem as described above. I have the same camera - PTZ Optics 20x USB (GEN-2).


Any clarity on this?


Thanks.


Aaron

Hi Aaron,


Sorry to hear that you are experiencing a video freeze issue with your PT20X-USB-XX-G2 camera.


If you could share some additional information about your setup we'll be able to start identifying any possible causes


  • What are the specifications of the Mac that is being used?
  • Are there are USB extensions being used to extend the USB signal?
  • Are there any USB hubs being used with the camera?
  • Has the firmware of the camera been updated recently? (Past 6 months)
  • What software are you using to interface with the USB video feed? (ECamm, OBS, Zoom, etc...)


We look forward to hearing from you again when you have the opportunity so that we can begin to make suggestions for resolving this issue.

My camera freezes only when I open you tube studio   I am using HDMI to  inogeni  usb is all 3.0   When this happens and I go to settings I see the Inogeni video has gone to red print as though the connection has terminated.  I am using obs software.


Hi Mike Cox,


I would start by looking at the resolution settings for your HDMI output and ensuring they are compatible with the Inogenis ingestion options.


My brief research suggests that all of our resolutions & frame rates for PTZOptics should be compatible with the Inogeni.


It would be worth viewing the cameras OSD, using the IR Remote and maybe an HDMI compatible display, to ensure that in the SETUP section the DVIMode is set for HDMI and not DVI.


If the signal only drops when you attempt to access the Inogeni via YouTube Studio I would be curious if there is a firmware update for the Inogeni?


If there is not a new edition of firmware and or a new version does not resolve the issue I would recommend testing this setup on a another UVC capable platforms


This could be the free trial of AMCAP or Zoom.US, etc...


If there is a "bug" in the Inogeni preventing use with YouTube Studio this information will prove very helpful for the Inogeni support team.


If there is anything else we can do to be of assistance please do not hesitate to let us know.



Login or Signup to post a comment