Start a new topic

Setting IP Address

This is an issue I thought was solved but it has now returned - When setting the IP address for a camera using the Multi Camera Setting window, then clicking on OK, the address is not saved and therefore control of the camera is not available.

I'm using a Mac Mini with a M1 chip and the latest software release for the camera control app.

Will appreciate a solution to this problem.


Hi Barry,

First, I would make sure that you are running the latest version of the Mac control app. The newest version (v1.4.1) was posted just last week so you may still be running the previous version (v1.4).

When adding the camera's IP address under that Multi Camera Settings section there are a few things you want to confirm. 

First be sure that there are no formatting errors/typos in the IP address itself.

Make sure that the IP camera dial next to the field where you enter the IP address is selected. (The selected dial is filled in black) If the USB camera dial is selected, anything you enter for the IP will not save.

Finally be sure to click OK at the bottom of the window for any changes to save. 

Oops!! I thought the selected button was the white circle, like a lit button.  A bit confusing.

Thanks for the clarification.

Due to other issues, I had to put this project on hold for about 2 weeks. 

I've downloaded 1.4.1 and I'm able to properly confirm and save the DHCP IP address for our camera, but I'm not able to control camera PIZ functions or see camera video using your controller app. 

Will appreciate any further help you can provide.

Hello Barry,

Are you sure that the camera has a good IP address in your network's range?

Are you able to access the Web GUI of the camera by typing the IP address into the URL bar of a web browser (default username and password are admin)?

If the camera's Web GUI is accessible, you should be able to add it to the control app and have control.

You would want to make sure the camera is added to the tool correctly (discussed above), then you would just need to select the correct camera select button on the main control panel and you should have control. 

Hi Colin,

I think I've determined what caused this problem. First, I have a medical condition that prevents me from being in our AV booth, so I'm depending on my tech to be my eyes when setting up this camera. When I asked him to press *#4 on the IR remote to display the correct IP address, it was not displayed long enough for him to properly see it then write it down. He then let me know it matched the one we were using in the multiple camera setup. I'm guessing this wasn't the case. We'll try this again!


Hi Barry,

I would double check the IP like you said and make sure you can access its Web GUI.

If you are still having trouble getting it working, feel free to give us a call. We should be able to help get things configured correctly.

The support number is 484-593-2584.

Support is available from 8 AM to 6 PM EST, Monday through Friday. 

Hi Colin,

Thanks for the support number info. I will contact them on Monday. My tech and I tried to work on our problem today, Saturday, and were able to get the controller app to operate the camera, to a degree:

1. We downloaded app v 1.4.1

2. When attempting to attach camera video to the app controls using Preview, camera video is displayed full screen hiding the controls.

3. Control of camera PTZ functions seemed to come and go. Not sure why this was happening.

4. It appears the latest firmware release for our camera is 6.3.29. Using *#8 on the IR remote, ARM is 6.3.91 and SOC is 6.3.12. It seems we need to upgrade our firmware but not sure how this is accomplished.

Will call Tech Support on Monday.


Hi Barry,

You can download the latest firmware for your camera from our Firmware Finder.

The Finder should provide the firmware file, a link to the Upgrade tool, and instructions for applying the update.

If you give us a call, we should be able to help walk you through the process. 

Login to post a comment