Start a new topic

Tips, Tricks and Troubleshooting

Welcome to the PTZOptics forum(s)!


This thread has been created for end users to discussions tips, tricks and troubleshooting for networking equipment with the PTZOptics Cameras


Please make sure to respect the experience level(s) of all users at all times when posting within our forums or your account may have access removed.


I have setup a static IP address on my camera as 10.1.1.249.  I can ping it successfully from my PC (10.1.1.217)


I try opening the rtsp stream both from a web browser and VLC.  The web browser drops straight through to google search and VLC fails with the following error:


VLC is unable to open the MRL 'RTSP://10.1.1.249:554/1'. Check the log for details.


From the setup I confirmed that the RTSP port is in fact 554


Can you help me resolve the issue?


Thanks,


Hi Doug,


Happy to assist here...


So we have a good starting point with the two (2) IP addresses operating under the same network scheme (10.1.1.XXX)


So just as a side note modern browsers are unfortunately incapable of decoding an RTSP stream however your second option of VLC should do the trick.


So let's take a moment just to walk through opening the feed in VLC just in case a small step was missed...


Once VLC is open use either the key combo of CTRL + N or the "Media" drop-down to select "Open Network Stream..."


Now in the "Please enter a network URL:" provide the following RTSP string... rtsp://10.1.1.249:554/1 (First Stream) or rtsp://10.1.1.249:554/2 (Second Stream)


Click "Play" and you should begin to receive a video feed from the camera.


If for any reason that does not work; please come back and we can further assist in determining where the flaw may exist in possible network settings or encoding parameters.


If you are simply trying to view this and using the cameras WebUI would be acceptable you also have the option to navigate to the "Video" section of the WebUI and set the "Second stream" to be "MJPEG" in the "Encode Ptorocol"


Click apply and reboot the camera; you should now from the "Live" section of the cameras WebUI a feed from your camera (note the preview window drop down must be set for "JPEG".


I look forward to helping you get to the bottom of this oddity if none of the above information proves helpful.




Thanks Matthew, turns out the first stream doesn't work, but the second stream


rtsp://10.1.1.249:554/2


works great!


JT Username change option does not show up in Chrome browser (latest: v. 36). I had source to switch to IE 11 in order to find it.

Hello, I am having this same problem.


I can view the video feed in the NDI studio monitor, and OBS, but not the preview window of the PTZ control program, or VLC with RSTP.


Here are my network settings: 

image


And this is what I get in VLC when I try to open the stream:

image


I have enabled logging in VLC, but it doesn't send anything to the logging output, so no clues there.


Any ideas?


OK never mind, I realized I was spelling it "RSTP" instead of "RTSP".


It will load in VLC now!  Would still like to know why it doesn't show in the PTZ control app though.

Login or Signup to post a comment